• Please review our updated Terms and Rules here

Pet 8296 blown fuse with monitor connected, and no chirp sound

demonlg

Veteran Member
Joined
May 22, 2016
Messages
501
Location
Italy
Hello with other machine and other issue.

This is my 8296 system, this system worked from 2006 to 2015 without problem, i have onli replaced a rom with a new eprom when buyed. Now the machine stays powered of from 2015 to 2024, but if i try to power on the main fuse going to blown!
I have escluded the power supply wires for the monitor and now the fuse is ok when i turn on it, probably i have a short in the monitor board, but the logic board do not have a chirp sound.

Only socketed chip are ROMS and 6502 CPU. Where i have to check first on this machine for troubleshoting the logic board?

I have another video board of an old series 8032 model, can i use it on 8296? Is not equal board!

Thanks

Emanuel
 
Last edited:
If it worked before sitting idle for 9 years and now blows fuses, I'm going to guess that you have one or more dead electrolytic caps.

As for why you don't have a start-up chirp, start with the basics: check the main board's power rails first, and if those look OK, make sure the 6502 has a good clock. Do you have an oscilloscope?
 
>>> and now the fuse is ok when i turn on it

Whatever happened, there was probably a large current surge that blew the mains fuse. I understand from what you are saying that the mains fuse stays intact now.

>>> probably i have a short in the monitor board

That is just purely a guess isn't it? It may be correct, it may not be correct.

>>> but the logic board do not have a chirp sound.

The monitor is powered from a separate winding on the transformer. If the monitor is faulty, this should not affect the logic board - but it is not chirping. This indicates that the problem is on the logic board and not the monitor. However, it could also be that you have a double-fault - one on the monitor and one on the logic board. Highly unlikely, but still possible.

If I was to hasten a guess, it would be a tantalum bead capacitor that has gone faulty on the logic board - and is causing the voltage regulator(s) to shut down. But that is also a guess.

If you have working machines, you should power them up at least once a year and leave them running for an hour or so. This prevents electrolytic capacitors etc. from dying a death!

You need to measure the voltage rails on the outputs of the various voltage regulators. Let's go for the logic board first (as that is easier to get to).

Dave
 
The logic board voltage regulators are ok, i have correct +5v and +12v, no voltage drop on logic board, the fuse not blown when i disconnect completely the monitor.
I have replaced only electrolityc capacitor because all have a little leackage, but not damaged the board.
 
Does the fuse blow when you connect the monitor? Or don't you want to try that?

Is this an 8296-D?

Dave
 
No it is a normal 8296 without internal drives, and yes fuse blow only when i connect the monitor.
 
Ok.

Looking at the monitor schematic there is C901 (47uF 16V) directly across the +12V incoming supply. Check this baby fir a short circuit.

There should be a 2A fuse in the monitor (F901) that should blow. Has someone replaced this fuse with a higher rating (or a nail)!

Dave
 
Ok monitor repaired, voltage regulator fault and now it's ok and fuse don't blow.

But i have black screen, no chirp on boot.
I have found three Logic chip with very hot temperature, two 74ls245 marked mos 65245 and One 74ls374. Now same black screen but chips not warm.

I have checked with scope on CPU and all address lines are stucked to 5v without pulse, data lines have pulse but only D3 Is flat, i have tested CPU in other computer and Is ok.

Then One of PLA on U5 position serms not have activity.
 
Last edited:
Can you check for activity on CPU pin 7 (SYNC).

Also can you check for activity (and voltage level) on the VIDEO, HDRIVE and VDRIVE signals from the logic board to the monitor.

Dave
 
Hi Dave,

The Sync on PIN 7 of 6502 stay low everytime, only of i push reset button i see a wave for one second, then nothing.

Photo attached are the video output on the board:

165549 horizontal
165656 vertical
165910 video

I have replaced 6545 with a working one but same issue, black screen, alzo the CPU with working one but nothing.

Now only both PLA's and CPU are hot, other chips normal temp After about 10 minutes with power on.

Sorry, a question, the screen tube when disconnected from board and with luminance at High value, have to give me a green raster or not? Because i don't have any raster or retrace lines.

The tube heater Is on correctly.
 

Attachments

  • IMG_20240225_165549.jpg
    IMG_20240225_165549.jpg
    2.3 MB · Views: 5
  • IMG_20240225_165656.jpg
    IMG_20240225_165656.jpg
    2.5 MB · Views: 5
  • IMG_20240225_165910.jpg
    IMG_20240225_165910.jpg
    2.3 MB · Views: 4
Last edited:
The CPU halting after a period of time could signify a ROM or a RAM issue.

You have (what appears to be) HDRIVE and VDRIVE but no video. I will check the situation with a low level on the VIDEO signal in a moment for you.

Dave
 
Hang on a minute...

The frequencies of HDRIVE and VDRIVE are all wrong. They are way too low!

HDRIVE should have a period of approximately 54 us.

VDRIVE should have a period of approximately 20 ms.

A 'low' signal on VIDEO should illuminate the CRT as green (or white). A 'high' level should be black.

Dave
 
Last edited:
Ok, with my video signal on screenshot i have a low signal right? But i don't have green screen!

I have another new working video board try to replace it?
 
If you don't have the correct HDRIVE signal, it is unlikely that you have the correct high voltages (in particular E50 - used in the video driver circuit to the cathode of the CRT).

Dave
 
Ok i have checked with scope on ram and i have found one chip with no data out, i have piggy backed this chip and now i have a chirp on boot, but only half pieces of chirp sound....not complete chirp in pratice. No video on screen, but the video signal Is present now.

Try to solder new ram with socket
 
Last edited:
Sorry mistake, i have also replaced both PLA with eprom 27c512 and socket adapter, One of PLA result defective, the UE6.
 
Socketed and replaced ram in UB5 and same results with previous piggy test, now the system give me a not complete chirping on boot, but screen Is black too!

Attached the image of actual signal on video connector, with two new pla and new ram now, i have tested two different video boards.

Now at this status i have on CPU PIN 7 Sync a wave pulse and address Lines pulse too, but After about any seconds all lines stop to pulse, and dataline too...

The CPU irq PIN 4 stay High during the Little boot chirping, then going to low.

Then I have checked output of PLA's and i have signals only when i have Activity on Sync and address Lines on CPU, but when It stop the output of PLA stop too.

photos:
010412 vertical drive
010455 horizontal drive
010619 video signal
012426 CPU Sync signal when present
 

Attachments

  • IMG_20240226_010412.jpg
    IMG_20240226_010412.jpg
    2.5 MB · Views: 4
  • IMG_20240226_010455.jpg
    IMG_20240226_010455.jpg
    2.4 MB · Views: 5
  • IMG_20240226_010619.jpg
    IMG_20240226_010619.jpg
    2.4 MB · Views: 5
  • IMG_20240226_012426.jpg
    IMG_20240226_012426.jpg
    2.4 MB · Views: 5
Well, the HDRIVE signal is still not the correct frequency. Therefore, replacing the PCB in the monitor doesn't tell us anything (as per my previous post).

The CPU is probably programming the CRTC incorrectly and is then halting at some point. This will explain the permanent LOW on the CPU /IRQ pin if the peripheral chips have been programmed and then the CPU halts.

I still think this is a ROM or a RAM issue, but randomly poking about is not going to help I am afraid.

Is it possible for you to burn a copy of my PETTESTER into an EPROM and install it in place of the EDIT ROM in UD8?

Failing that, would you be willing to buy a ROMulator from bitfixer or Nivag to help diagnose this fault in a more logical manner?

Dave
 
Yes, i have blank eproms and programmer, what eprom i need, and what i find your pettester?

I have tyed the KERNAL/BASIC ROM from my 8296D (other computer to restore) and i have replaced it with new one programmed eprom, but the issue is the same, little not complete chirpchirp at boot
 
Back
Top