• Please review our updated Terms and Rules here

Sinclair QL with SPEM Floppy Disk sistem 1.16 (sistem with the "i" and not the "y")


Experienced Member
Aug 27, 2016
Turin, Italy
Dear Group,
I have been given a system like the subject.
Everything has been ok for some minutes... I have been able to read a dir of a floppy and then to launch a program from that floppy.
Then I wanted to make a case with two black floppies, one 5.25 and one 3.5 (both included in the kit, but with the 5.25 not black) , so I tried other FDDs... obviously after a while I had the doubt that the FDDs for the QL are not completely the same as the ones for the PCs... I remounted the original 5.25 FDD and... drama! Now it doesn't work anymore! :-(
It cannot read anything. The best thing it does is when I format a FD: for the first run it moves flawlessly while for the second it "grins"... :-(
I am thinking I have done something wrong but I cannot see what...

In the meantime I have discovered the 3.5 FDD is not good since it cannot block a FD inside... but anyway all programs included in the package are in 5.25 disks so I suppose that this drive was bad from the beginning.

Thank you for the help


  • PIC_20240310_172728.jpg
    4.1 MB · Views: 17
Have you got a known-working more modern 3.5" drive you can try with it, e.g. one from a PC? It will work fine but by default a PC drive will be jumpered as DS1 (not DS0) which will mean that the QL will see it as FLP2_, so dir FLP2_ to access etc.

Also remember that the original 3.5" drive(s) that such a device would have been supplied with were 720k drives and the SPEM interface will only format to 720K (or 1440x 512b sectors) so it's best to test and use it with DD 720k disks for better reliability.
All modern PC 3.5" floppy drives are normally factory set to DS1 and the twist in the cable differentiates when 2 drives are connected. With QL disk interfaces (all the ones I have seen) there is a straight cable with no twist before either drive and the floppy ID is set on the drive itself by a jumper, so both have to be set differently. Use a straight cable, or the straight part of the cable with nothing connected to the connector after the twist.

I've also found that not all QL disk systems have pin 1 on the red striped edge of the cable, so also make sure the ribbon cable is the correct way - if the drive light illuminates as soon as power is applied then it's the wrong way round.
I have some drives but I haven't seen any jumper! :-( Perhaps they are under the external metal skin... I have tried what you proposed, I have disconnected the 5.25 drive and connected a modern 3.5 one but it does not work. I am afraid this is a limit of the SPEM HW... I have tried the same with 5.25 drives and I had no good results... the good part is that today I have been able to revive the 3.5 drive... it was only "stuck" after a long period of unusing. I have 3D printed some parts and I have made an external case! What do you think (please find attached some photos)?


  • PIC_20240317_173057.jpg
    2.8 MB · Views: 5
  • PIC_20240317_173130.jpg
    1.3 MB · Views: 6
  • PIC_20240317_173902.jpg
    5.4 MB · Views: 6
Yes, if there is a jumper on modern drives it's often a couple of solder pads to bridge. 1.44mb drives are normally fine on QL interfaces, but they can only be used as a 720k drive, just like the original 3.5" drive that it would have come with.

Oh well, you got it working in the end and looks good.

If you have an eprom reader, save the SPEM eprom contents and share it, it could be useful to someone else one day.
I used to work at Sandy, which was a partner company of SPEM.

The Sandy Superdisk and SPEM interfaces had a lot in common and shared a common ROM image up to 1.16. The Sandy Superdisk evolved into the SuperQBoard over time. Sandy ROMs should work in SPEM products and vice versa, though some features like parallel port or mouse may not be implemented.