• Please review our updated Terms and Rules here

Bit of curiosity--Imation SuperDisk difference between blue and clear cases?

Chuck(G)

25k Member
Joined
Jan 11, 2007
Messages
44,954
Location
Pacific Northwest, USA
Like the subject says, I've got SuperDisk drives with the blue "nose" and ones with the "clear" one. Other than the color, is there any practical difference? I can't tell any. Were the blue noses intended to go with the iMac G3?
 
One thing that I've discovered is that the "clear nose" SuperDisks use M3.5 mounting screws, whereas the "blue nose" SuperDisks use UNC 6-32 screws. There are other minor differences, but nothing substantial yet.
 
What I remember is that Imation had both Superdisk cases out there at the same time with whichever drive mechanism was current so you could get Imac cute with either older or newer drives. Even worse, there were stealth revisions where the drive mechanism or the bridge chips changed but the official model number didn't. The MSFN thread that abused the SuperDisk would show some of the differences but those didn't seem to be things that would come up in normal use.
 
The Imation ATA-to-USB adapter appears to be non-model specific (at least the one that I have). For example, it works quite nicely with Caleb UHD144 drives. The LS120 drives themselves are useful for providing a PC without native floppy support, but with IDE the ability to handle diskettes.
I wonder how many LS120 floppies were actually used in those drives, as opposed to standard DD or HD floppies. It does have an advantage over regular drives as it runs at double-speed.

Of course, Windows users may have problems with this, but Linux sees it just fine.
 
A fun stupid pet trick when you had an LS120 instead of a regular floppy was you could soft-eject a disk using the same commands as a PATA CD-ROM drive. Suck it Mac-loser, I can have power eject floppies on my PC too!
 
Yeah, that too. Even supported on Linux. Gotta admit that I'm a bit conflicted on that feature--always struck me as another damned thing to go wrong...

Only partial support on more modern Linux kernels.

I have a couple of IDE LS-120 drives and I have to use an IDE to USB adapter for them to work on Linux. Otherwise they will show up as a device, but you can't read or write disks. But even though it will work with the USB adapter, you can't use LS-120 disks, it just makes the file explorer crash or partition managers to vomit.
 
That's strange--those Public Brand Software disks I posted were read on an LS120 connected to the IDE header on an AM3 board (hard disks are SATA). Setup was Debian Bullseye. No issues. Haven't tried it on Bookworm, but I don't see why it wouldn't work. Could your problem have been the IDE support on your particular board?

I've used the USB adapter on a Caleb UHD144 drive with the appropriate UHD floppy on Bookworm. Again, no issues.

Maybe I'm living under a favorable star...or maybe Debian is really conservative. Of course, my mode of operation is pretty much CLI. Don't care for the GUI stuff if I can avoid it.
 
Last edited:
I've tried numerous IDE controllers, LS-120 never works for me on them. I use Fedora, Xubuntu and OpenSUSE. The drive icon will show up, but you can't mount any disks.
 
Strange, that. Don't know what to tell you:

Code:
[0:0:0:0]    disk    ATA      TEAM T253512GB   0.2   /dev/sda 
[1:0:0:0]    cd/dvd  Optiarc  DVD RW AD-7240S  1.03  /dev/sr0 
[2:0:0:0]    disk    MATSHITA LS-120 VER5   00 F515  /dev/sdb 
[6:0:0:0]    disk    Generic  USB SD Reader    1.00  /dev/sdc 
[6:0:0:1]    disk    Generic  USB CF Reader    1.01  /dev/sdd 
[6:0:0:2]    disk    Generic  USB SM Reader    1.02  /dev/sde 
[6:0:0:3]    disk    Generic  USB MS Reader    1.03  /dev/sdf 
-----
Architecture:                       x86_64
CPU op-mode(s):                     32-bit, 64-bit
Byte Order:                         Little Endian
Address sizes:                      48 bits physical, 48 bits virtual
CPU(s):                             4
On-line CPU(s) list:                0-3
Thread(s) per core:                 1
Core(s) per socket:                 4
Socket(s):                          1
NUMA node(s):                       1
Vendor ID:                          AuthenticAMD
CPU family:                         16
Model:                              5
Model name:                         AMD Phenom(tm) II X4 840 Processor
Stepping:                           3
------
Distributor ID:	Debian
Description:	Debian GNU/Linux 11 (bullseye)
Release:	11
Codename:	bullseye

I gave up on Ubuntu some time ago after it opted for "bleeding edge" versioning.
 

Attachments

  • Screenshot_2024-02-28_13-10-25.png
    Screenshot_2024-02-28_13-10-25.png
    74.4 KB · Views: 4
Yeah, that too. Even supported on Linux. Gotta admit that I'm a bit conflicted on that feature--always struck me as another damned thing to go wrong...
All the mac eject gears turning to dust would give this a post a fact check: true
 
Back
Top