• Please review our updated Terms and Rules here

recovering an SGI indigo

hush

Experienced Member
Joined
Feb 7, 2022
Messages
317
Location
MD, USA
hey all, i have an unhappy indigo in my collection- i recently replaced the CPU battery since the diagnostic LED was yellow and i could get nothing on my display. this fixed the issue with the yellow LED and the CPU seems happy from the outside, but now i am still getting nothing on the display and no startup chime. i have a universal 13w3 to vga adapter that works on my sun ultra 60- none of the configurations i have tried work for the indigo. disks and keyboard light up so they are getting power, and there is occasionally a nasty squelch from the speaker when i turn the box off. anyone able to think of anyone obvious i should look at or am i breaking out the scope?
 
Check this link:


Not all 13W3 connectors are compatible with each other. If it works on a Sun, it may not work on an SGI...

Dave
 
correct, but i think that at least one of the configurations i've tried should have worked. someone on an SGI forum also did report getting this working with another machine, though i don't recall which and would have to hunt for a link. unless the cable is just bad?
 
ended up hacking together a serial adapter with the following wiring and getting nothing; assuming this is correct i think i have a dead cpu :(

Code:
DB9            Mini-DIN 8
2 (RX)   <-->  3 (TX)
3 (TX)   <-->  5 (RX)
5 (GND)  <-->  4 (GND)
 
You could always try swapping TX and RX at one end and seeing what happens. You have nothing to lose!

Or one side (or both) require hardware handshake lines... Just jumper them out at both ends to be sure...

Dave
 
still no dice, sadly... went into the indigo manual as well and pulled out this pinout, and i still get nothing :/ tried pulling the graphics board too, looks like it's just dead

fdasf.PNG
 
Has your power supply been serviced at all? Those have been needing capacitors since the late 2000's
i didn't see anything when i looked it over, but i'll give it a deeper look when i have the spoons
 
Hey Op - Any updates? I just (within the last couple of hours) have experienced the same situation as you; Indigo was unable to boot with 'unable to set tod clock' message. So I ordered this battery, replaced the old one, and now my Indigo doesn't boot at all; the only thing that does happen is two rapid LED flashes on the keyboard, along with a happy green LED on the CPU board.

I did do some extra steps that yielded interesting results; I checked with a multimeter that I didn't bork any of the traces on the board, and that I get the expected 3.6v on the traces themselves.

Now the interesting bit; I pulled the new battery back out, and the machine came up just as before, chime, 'unable to set tod clock', no issues.

So, I'm curious if:
- there is a soak period with the new battery
- or if this battery is trash, or
- if the battery is fine, but there's another issue with the board that the dead battery was masking?

Best of luck - If I get anywhere I'll follow up.
 
Last edited:
Follow up with further diagnostics:
- Connected serial adapter to see if I could get any output there, no luck
- No change with a minimal SIMM count, no change after swapping SIMMs around

If I can't think of anything else, I'll start reseating socketed ICs and maybe look for another brand/supplier for that type of battery.

Found a related thread from 2013: https://gainos.org/~elf/sgi/nekonomicon/forum/3/16727388/1.html
 
Last edited:
The first thing I'd suggest is to double-check the polarity of that battery!
it's not impossible to insert the battery backwards but at least on my cpu board it would hang so far off the edge you would be visibly doing something wrong

my current guess is that something in the power supply is unhappy but i haven't had the time or motivation to rip it apart and start looking, sorry
 
Put the new battery back in and started isolating components on the graphics board. As soon as I pulled the ZB4 buffer card, I got a chime and an amber LED on the CPU board. On closer inspection I found C55 had met its fate at some point in time. Now to find the value and get a replacement cap soldered in.

1000005187-01.jpeg
 
One last followup from me; Indigo is back in action. The service manual clearly states that the buffer card is not required for operation. Sure 'nuff the system seems to be operational. Cheers!
 

Attachments

  • PXL_20240324_022503832.jpg
    PXL_20240324_022503832.jpg
    2.3 MB · Views: 13
Back
Top